5 怎么在Tron网络上部署智能合约

用Tron IDE部署合约到Tron网络上发现Tron最新只有0.8.6版本编译器,但是我的合约的版本声明用的是pragma solidity 0.8.21,使用Tron IDE 无法编译。请问我应该怎么解决。 有没有办法在不降低使用编译器版本的情况下部署合约,比如使用部署脚本等等。

f34d943d2461ac80831b60a713e9d2f.png 我将版本降到0.8.18后,Tron IDE显示不支持ether单位。但是通过remix测试得知0.8.18版本是支持ether的。

image.png

请先 登录 后评论

最佳答案 2023-11-16 11:32

我搞清楚了,Tron目前最多只支持到solidity0.8.20版本。Tron不支持ethereum的ether单位,它自己的单位是trx和sun。感谢各位的回答和帮助。

请先 登录 后评论

其它 3 个回答

Tiny熊 - 布道者
  擅长:智能合约,以太坊
请先 登录 后评论
我不吃香菜
请先 登录 后评论
IT_浩哥 - 接区块链DAPP开发
请先 登录 后评论
  • 5 关注
  • 1 收藏,652 浏览
  • Joe 提出于 2023-11-14 15:30

相似问题